GuideCenter Mobile Discontinued

Incident Report for Finlife Client Experience Status

Update

We are continuing to investigate this issue.
Posted Jun 05, 2026 - 14:05 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2026 - 14:04 PDT

Investigating

The scheduled update is currently in progress. The platform should remain available throughout this update. This message is intended for awareness in case issues occur while the upgrade is in progress. We will provide updates as necessary.
Posted Jun 05, 2026 - 14:02 PDT

Update

Usage will continue to be monitored to inform the final deprecation of the mobile applications
Posted Jun 05, 2026 - 14:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 13:15 PDT

Investigating

Notice: The GuideCenter mobile app (iOS & Android) will be permanently discontinued on June 12, 2026
The web version is not changing, and all your data remains available.
For questions, please contact your financial advisor.
Posted Jun 05, 2026 - 13:14 PDT
This incident affects: AdvisorCenter, GuideCenter, HonestConversations, MoneyMind, Salesforce, Wealthbox, MoneyGuide, Redtail CRM, Tamarac CRM (Microsoft Dynamics 365), and eMoney.